BGP Aggregation | Summarization

1080

BGP Aggregation | Summarization :-

  • It reduces the size of routing table.
  • It minimizes the number of routing updates.
  • To summarize network at least one subnet must be in BGP table.

Syntax: –

R(config)# router bgp <AS No.>

R(config-router) #aggregate-address <Network Id> <Summary Mask>

BGP Aggregation | Summarization Lab: –

BGP Aggregation | Summarization

As per above diagram basic IP addressing and BGP are configured on Router R1, R2, R3.

Basic ip addressing & BGP are configured on Router R1.

R1#sh run | s interface Serial1/0
interface Serial1/0
ip address 1.1.1.1 255.0.0.0

R1#sh run | s bgp
router bgp 500
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
neighbor 1.1.1.2 remote-as 600
no auto-summary

Basic ip addressing & BGP are configured on Router R2.

R2#sh run | s interface Serial1/0
interface Serial1/0
ip address 1.1.1.2 255.0.0.0

R2#sh run | s interface Serial1/1
interface Serial1/1
ip address 2.2.2.1 255.0.0.0

R2#sh run | s bgp
router bgp 600
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
network 2.0.0.0
neighbor 1.1.1.1 remote-as 500
neighbor 2.2.2.2 remote-as 700
no auto-summary

Basic ip addressing & BGP are configured on Router R3.

R3#sh run | s interface Serial1/1
interface Serial1/1
ip address 2.2.2.2 255.0.0.0

R3#sh run | s Loopback
interface Loopback0
ip address 13.0.0.1 255.255.255.0
interface Loopback1
ip address 13.0.1.1 255.255.255.0
interface Loopback2
ip address 13.0.2.1 255.255.255.0
interface Loopback3
ip address 13.0.3.1 255.255.255.0

R3#sh run | s bgp
router bgp 700
no synchronization
bgp log-neighbor-changes
network 2.0.0.0
network 13.0.0.0 mask 255.255.255.0
network 13.0.1.0 mask 255.255.255.0
network 13.0.2.0 mask 255.255.255.0
network 13.0.3.0 mask 255.255.255.0
neighbor 2.2.2.1 remote-as 600
no auto-summary

Lets check advertised route on Router R2

Lets summarize the network- 13.0.0.0/24, 13.0.1.0/24, 13.0.2.0/24, 13.0.3.0/24 with 13.0.0.0/22, On Router R3

Lets check again advertised route on Router R2

See above network- 13.0.0.0/24, 13.0.1.0/24, 13.0.2.0/24, 13.0.3.0/24 are summarized with network- 13.0.0.0/22.

LEAVE A REPLY

Please enter your comment!
Please enter your name here